Make your own free website on Tripod.com

Unless you have Windows XP, you will need WinZip 6.0 or better. I know for sure that WinZip 8.1 will work. I have not tried the beta for version 9.0 yet.
If you want to register your version of WinZip, e-mail me.

Have Four Winds Mahjong v2.01? Register it.

Chocolate Missile spreadsheet

Virgin Martini spreadsheet